fbpx

WordPress 2.8 正式版出爐(含中文語系)

WordPress在前陣子釋出2.81、2.82beta測試版後,本以為正式版可能是2.9或3.0版才推出,但是直接釋出了WordPress 2.8 Baker正式版,這版本如同先前2.8x的測試版釋出的功能差不多,不過正式版上實際新增的聽說是修正了790個BUG之多,可見先前的2.71版本真是個危險的東西(但其實也沒出什麼事啦),不過也先不用急著升級,畢竟版本換了一個,直接升級可能會造成佈景或外掛不符的情況哦!

WordPress 2.8 (Baker)正式版:

官方網站:http://wordpress.org

軟體名稱:Wordpress

軟體版本:2.8 正式版

軟體下載:http://wordpress.org/latest.zip

語系下載:正體中文簡體中文

正體中文Wordpress懶人包:請點我下載

懶人包就是幫你把正體中文語系放進Wordpress檔,語系也幫你選好中文了,架設時只需要編輯資料庫的資訊即可。

聽說這一版新增了180個以上的功能,雖然親自安裝一個來玩之後並不會感受到有這麼多,不過詳細新增的功能可以參考官方文件:http://codex.wordpress.org/Version_2.8

這次在佈景的功能部份加強了許多,除了大家已經很清楚的新增佈景功能和模組的自訂欄不同外,在後台佈景的編輯介面強化了許多,不僅自動標示程式碼,還加入了行號,在編輯上更清楚方便。

新增佈景功能及自訂模組介面介紹由此去:https://steachs.com/archives/763

02

在佈景的功能中還加入了自定頁首(Header)的功能,也算是頗為方便,不過也有可能因為佈景不符合可能就無法使用此功能。

03

其它像是針對寬螢幕設計的首頁欄位數規劃功能,原本預設是2行,在這個版本總共有1~4可以選擇,對於寬螢幕而言算是很便利的一項功能。

01

而在我們文章編輯的部份,原先每頁顯示的文章數都是固定無法調整的,有時在找文章或需大量編輯文章查看時很不方便,這次的版本裡新增了可自行調整文章顯示數量的功能,非常的實用。

04

其它新增的功能就比較沒有什麼是屬於比較重大或實用性質,不過目前2.8正式版因為才剛釋出,有不少的外掛會有衝突的情況,包括一些佈景也有問題,因此如果有想要升級的朋友建議你先到WordPress Plugin Compatibility Checker確認你目前使用的外掛有沒有尚未支援wordpress 2.8版本,最好是先另外安裝全新的測試一下,升級前也務必備份,否則升級掛點就來不及了~~

丫湯已經壓著心臟升級完畢了,目前沒有出現任何異狀,以下是丫湯的外掛列表,大家可以參考看看:

05

你可能對這些內容也有興趣

阿湯 作者:阿湯

對電腦 & 網路資訊充滿興趣與熱情、瘋了似的每日堅持發文,「阿湯」這個名字是由湯姆克魯斯而來的,雖然我沒有他帥氣,也不會演電影,但我會寫文章....

更多關於的文章》

17 個留言

  1. Avatar eeepage表示:

    hi~
    請問前台要怎麼繁中化~感恩~~

    阿湯說:

    前台要繁中化的話要直接修改佈景檔..

  2. Avatar 新手表示:

    裝上2.81
    就出現
    HTTP 500 – 內部伺服器錯誤
    Internet Explorer
    若是舊版的則是安裝畫面 ?
    請問這是哪有問題 ?
    Thanks…

    阿湯說:

    你將空間資訊寄到我信箱看看OK?

  3. Avatar Mark表示:

    WP 2.8 + Firefox 3.0.11 無法發表文章。XD

    阿湯說:

    應該不會耶,我沒有出錯

    可能是其它原因哦

  4. Avatar water表示:

    升級為2.8版後!外站RSS或後台會變成下圖所示變成亂碼!試問該如何是好?感謝回答!!!
    http://140.111.71.3/wpblog/wp-content/uploads/2009/06/28back2.jpg
    http://140.111.71.3/wpblog/wp-content/uploads/2009/06/28back1.jpg

    阿湯說:

    語系的關係,你有重放2.8用的語系檔嗎

    如果有應該是你wp-config裡的語系設定有誤

    應該是要utf-8

  5. Avatar derek表示:

    給使用Firefox瀏覽器的站長及使用者們:
    wordpress 升級到 2.8 後,發表文章介面在 Firefox2.0 環境下運作會有問題
    整個發文介面無法使用,將 Firefox 更新到最新版 (3.0) 後問題就解決了。

    還有在編輯程式碼的介面裡有提供高亮模式的功能,使用IE7瀏覽器編輯會有自動增加每行的換行數,以及游標會亂跳的情形,可在選項裡將高亮模式關閉,不知是不是我本身的問題~呵呵

    阿湯說:

    不過我都是用WLW編輯,沒這個問題…

    Firefox2.0應該用的也不多了..

  6. Avatar 梅干扣肉表示:

    唷~~正式版出了喔~~
    梅干還完全在狀況外~~
    還在用2.7版~~
    呵~~

    阿湯說:

    沒關係啦,偶而來丫湯家走走

    就會知道了……

  7. Avatar 野兔表示:

    像你那留言跟引用分開要怎麼做?
    網路上找到的都不太合我意,看到丫湯這留言系統,一整個很喜歡

    阿湯說:

    那是在留言版面中加入分頁的效果

    因為我的原先在佈景中就有加入

    所以我不用修改,如果你佈景原先沒有

    必需要修改不少地方

  8. Avatar Nova表示:

    我講的是我未來要用的新風格,我怎麼可能會在本尊上做手腳,一定是在備援站上面做的嘛~

    阿湯說:

    我還以為你這麼猛@@"

  9. Avatar Arno Ruan表示:

    addquicktag掛點了….但該網站卻說2.8支援OK…
    不知為何。ˊˋ

    阿湯說:

    我試了沒問題耶,你可能是某個外掛和他沖到了

  10. Avatar 野兔表示:

    所以我還蠻想知道怎麼改的
    看起來好像很不容易

    阿湯說:

    如果要改的一模一樣要改function加函數

    再加一個Ajax的php檔…

    另外再改CSS和comment.php,很麻煩@@

    如果只是要Ajax效果,可以加裝外掛就可以了

    可以參考這一篇http://steachs.com/archives/715

    不過不是每個佈景都適用…

  11. Avatar 野兔表示:

    丫湯這個留言迴嚮真棒!怎麼用的丫?

    阿湯說:

    這是寫進佈景的Ajax效果不是外掛啦

  12. Avatar 藍兒表示:

    你用的外掛還真不少耶! :as67

    阿湯說:

    還好啦~都是我自己需要用的

    別人還有更多的,有一些東西我寫進佈景了

    原本可能要更多一點

  13. Avatar 野兔表示:

    我也直接用WP2.8,蠻不錯的

    阿湯說:

    我昨天是先新架一個站試才按升級

  14. Avatar 好手表示:

    @好手
    結果我把東西放上去9iblog竟然莫名其妙就好了 一一 見鬼 :as35

    阿湯說:

    你不是說你硬過頭了= =

  15. Avatar xD~碳表示:

    碳碳就是有個外掛衝突,「Ozh-admin-drop-down-menu」
    至於其他的外掛目前沒什麼異常的部分

    (小聲道)ㄚ湯不是說不要裝那麼多東西嗎?(驚) :as33

    阿湯說:

    你那外掛還好,2.7之後就可以不用裝的

    那個在2.62之前比較有用

  16. Avatar Nova表示:

    林阿媽咧…改了老半天~新的風格幾乎要全部重來… :as20

    阿湯說:

    丫~Nova你沒有備份哦

    還好當初沒有衝突用你那佈景= =

  17. Avatar 好手表示:

    我用的版型沒辦法在2.8用…真慘XD
    第一個版型就碰到倒楣事

    阿湯說:

    不過應該有轉寰的餘地啦

    你那麼厲害,改一改就好了  XD

發表留言 »

姓名(*)
信箱(*)